보안이슈

보안이슈

게시물 상세
[EhostICT] Javascript JSONata 라이브러리 보안 업데이트 권고
작성자 : 관리자(marketing@ehostidc.co.kr)  작성일 : 2024-03-28   조회수 : 661

개요

 o Javascript JSONata 라이브러리 취약점을 해결한 보안 업데이트 발표 [1]

 o 영향받는 버전을 사용 중인 시스템 사용자는 해결 방안에 따라 최신 버전으로 업데이트 권고

  * JSONata 라이브러리 : JSON 데이터에 대한 경량 쿼리 및 변환 언어를 지원하는 라이브러리


설명

 o JSONata 라이브러리에서 발생하는 서비스 거부 및 원격 코드 실행 취약점(CVE-2024-27307) [1]



□ 영향받는 제품 및 해결 방안

취약점

제품명

영향받는 버전

해결 버전

CVE-2024-27307

JSONata

1.4.0 ~ 1.8.7 이전

1.8.7 이상

2.0.0 ~ 2.0.4 이전

2.0.4 이상

  하단의 참고사이트를 확인하여 업데이트 수행 [1] [2] [3]


기타 문의사항

 o 한국인터넷진흥원 사이버민원센터국번없이 118

[참고사이트]

[1] https://github.com/jsonata-js/jsonata/security/advisories/GHSA-fqg8-vfv7-8fj8

[2] https://github.com/jsonata-js/jsonata/releases/tag/v1.8.7

[3] https://github.com/jsonata-js/jsonata/releases/tag/v2.0.4



작성침해사고분석단 취약점분석팀


이전글 [EhostICT] WordPress 플러그인 보안 주의 권고
다음글 [EhostICT] Python aiohttp 라이브러리 보안 업데이트 권고