바로가기 메뉴
본문내용 바로가기
메인메뉴 바로가기



Customer Center

Notice · Security Issue · Account Guide · Global Traffic Test

HOME > Customer Center > Security Issue

보안이슈

리눅스서버 취약점, OpenSSL 긴급 보안 업데이트
2016.03.11

안녕하세요.

이호스트데이터센터 IDC사업부 입니다.

OpenSSL 취약점을 악용한 신종 DROWN, CacheBleed 공격이 발견됨에 따라 관련 긴급패치가 배포되어서 공유 전달드립니다.

□ 개요
o 3월 1일(현지시간) 오픈SSL은 SSLv2 규격(Protocol)에 대한 긴급 업데이트 발표[1]
o SSL 취약점을 이용한 신종 공격 방식인 DROWN, CacheBleed에 대한 보안 업데이트 등
- DROWN(Decrypting RSA with Obsolete and Weakened eNcryption)
- CacheBleed: 인텔 프로세서의 Cache-bank 충돌로 인한 정보 노출을 이용한 부채널 공격

□ 영향 받는 버전
- OpenSSL 1.0.1s 이전 버전 : 1.0.1s로 업데이트
- OpenSSL 1.0.2g 이전 버전: 1.0.2g로 업데이트
- OPenSSL 0.9.8zf 및 이전 버전: 1.0.1s 혹은 1.0.2g로 업데이트

□ 업데이트 내용
o SSLv2 프로토콜 비활성화 기본 설정 및 SSLv2 EXPORT 암호화 제거 등

□ 취약점 내용 및 권고 사항
o DROWN: 낡고 취약한 암호화를 통한 RSA 복호화
- RSA(Rivest Shamir Adleman): 공개키 암호화 알고리즘의 하나

CVEs심각도내용비고
CVE-2016-0800높음SSLv2를 이용한 TLS에 대한 프로토콜 간 공격DROWN
CVE-2016-0705낮음DFB, 발생 빈도 낮음
CVE-2016-0798낮음SRP 데이터베이스에서의 메모리 누수
CVE-2016-0797낮음널 포인터 역참조 및 힙 커럽션
CVE-2016-0799낮음고정 메모리 이슈
CVE-2016-0702낮음부채널 공격CacheBleed
CVE-2016-0703높음분할 정복 알고리즘
CVE-2016-0704보통Bleichenbacher 공격


□ 용어 설명
o DFB(Double-Free Bug): 힙 오버플로우에 기반을 둔 공격으로, 원하는 위치의 메모리를 사용하기 위한 방법
o 널 포인터 역참조(Null Pointer Dereference): 널 포인터에 임의의 값을 대입하여 발생하는 에러
o 힙 커럽션(Heap Corruption): 동적 할당한 크기보다 더 큰 영역에 접근함으로써 발생하는 에러
o 부채널 공격(Side Channel Attack): 알고리즘의 약점을 찾거나 무차별 공격을 하는 대신 암호 체계의 물리적인 구현 과정의 정보를 기반으로 하는 공격 방법
o 분할 정복 알고리즘(Divide-and-conquer): 그대로 해결할 수 없는 문제를 작은 문제로 분할하여 문제를 해결하는 방법
o Bleichenbacher 공격: RSA 암호화 메시지 내용을 점차적으로 노출하기 위한 공격

□ 문의사항
o 한국인터넷진흥원 인터넷침해대응센터: 국번 없이 ☏118

[참고사이트]
[1] https://www.openssl.org/news/secadv/20160301.txt



첨부파일