바로가기 메뉴
본문내용 바로가기
메인메뉴 바로가기



Customer Center

Notice · Security Issue · Account Guide · Global Traffic Test

HOME > Customer Center > Security Issue

보안이슈

PostgreSQL 취약점 업데이트 권고
2016.02.18

개요

o 오픈소스 데이터베이스관리 시스템(DBMS)인 PostgreSQL에서 권한상승 등의 취약점을 해결한 업데이트 버전이 발표됨
o 낮은 버전의 PostgreSQL 사용으로 권한상승 등이 발생할 수 있으므로 사용자의 주의 및 최신버전 업데이트 권고
□ 설명
o PostgreSQL의 3개 취약점을 해결한 보안 업데이트가 발표됨
- 특정 함수에서 권한을 확인하는 기능이 없는 취약점 (CVE-2012-0866)
- SSL 지원기능이 활성화된 경우 부적절한 인증서 검증으로 중간자 공격이 가능한 취약점 (CVE-2012-0867)
- 데이터베이스 오브젝트 이름에 ‘ "이 포함된 경우 SQL 인젝션이 가능한 취약점 (CVE-2012-0868)
□ 해당 시스템
o 영향 받는 소프트웨어
- PostgreSQL 9.1, 9.0
- PostgreSQL 8.4, 8.3
□ 해결방안
o PostgreSQL 9.1, 9.0 이전버전 사용자
- PostgreSQL 9.1.3, 9.0.7으로 업데이트
o PostgreSQL 8.4, 8.3 이전버전 사용자
- PostgreSQL 8.4.11, 8.3.18으로 업데이트
□ 용어 정리
o PostgreSQL : 객체-관계형 데이터베이스 관리 시스템(ORDBMS)의 일종으로 BSD 허가권으로 배포되며 오픈소스
개발자 및 관련 회사들이 개발에 참여하고 있음
o 중간자 공격(man-in-the-middle attack) : 통신하고 있는 두 당사자 사이에 끼어들어 당사자들이 교환하는 공개정보를
자기 것과 바꾸어버림으로써 신분위장, 재전송 등을 하는 공격
o SQL 인젝션 : 응용프로그램의 취약점을 악용해, 개발자가 생각지 못한 SQL문을 실행되게 함으로써 데이터베이스를
비정상적으로 조작하는 공격
□ 기타 문의사항
o 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118
출처: KISA
이호스트데이터센터(http://www.ehostidc.co.kr)
첨부파일