바로가기 메뉴
본문내용 바로가기
메인메뉴 바로가기



Customer Center

Notice · Security Issue · Account Guide · Global Traffic Test

HOME > Customer Center > Security Issue

보안이슈

OpenSSH Client 보안 업데이트 권고
2016.02.05

□ 개요
o OpenSSH Client에서 메모리 정보 노출 취약점 등 2개의 취약점을 해결한 보안 업데이트 발표[1]

□ 설명
o roamin_common.c 안의 resend_bytes 함수에서 메모리 정보 노출(Information leak) 취약점(CVE-2016-0777)[2]
o roamin_common.c 안의 roamin_read 함수와 roaming_write 함수에서 힙 버퍼오버플로우(heap-based buffer overflow)가 발생 (CVE-2016-0778)[3]

□ 영향받는 버전
o OpneSSH 5.x, 6.x, 7.x ~ 7.1p1

□ 해결 방안
o OpneSSH 7.1p2 로 업데이트

o Roming 기능을 비활성화

- 리눅스 및 FreeBSD

echo "UseRoaming no" | sudo tee -a /etc/ssh/ssh_config


- Mac OSX

echo "UseRoaming no" >> ~/.ssh/config


□ 용어 설명
o 버퍼 오버플로우(Buffer Overflow) : 특정 프로그램에 할당된 메모리 영역을 초과하는 크기의 데이터를 입력시킴으로써 발생하는 취약점

□ 문의사항
o 한국인터넷진흥원 인터넷침해대응센터: 국번 없이 118

[참고사이트]
[1] http://www.openssh.com/txt/release-7.1p2
[2] https://web.nvd.nist.gov/view/vuln/detail?vulnId=C...
[3] https://web.nvd.nist.gov/view/vuln/detail?vulnId=C...

첨부파일