바로가기 메뉴
본문내용 바로가기
메인메뉴 바로가기



Customer Center

Notice · Security Issue · Account Guide · Global Traffic Test

HOME > Customer Center > Security Issue

보안이슈

EhostIDC. Apache Struts 원격 코드 실행 취약점 업데이트 권고
2017.03.23

최근 중국발 다양한 침해시도 및 사고가 빈번히 발생하고 있습니다.

해당 메일을 수신한 전산 담당자께서는 아래 내용 확인하시어 피해를 입는 사례가 없도록 관리하시기 바랍니다

□ 개요
o Apache Struts에서 임의 코드 실행이 가능한 취약점을 해결한 보안 업데이트 발표 [1]
o 취약한 버전을 사용 중인 서버의 담당자는 해결방안에 따라 최신 버전으로 업데이트 권고

□ 내용
o Jakarta Multipart 파서를 기반으로 한 파일 업로드를 수행할 때 HTTP Request 헤더의 Content-Type을 변조하여 원격 코드 실행이 가능한 취약점(CVE-2017-5638)

□ 영향을 받는 제품 및 버전
o Apache Struts 2.3.5~2.3.31 버전
o Apache Struts 2.5~2.5.10 버전
※ 버전 확인 방법 : web하위의 /WEB-INF/lib/struts-core.x.x.jar 파일 버전 확인

□ 해결 방안
o 취약점이 해결된 버전으로 업데이트 수행
- Apache Struts 2.3.32 버전 [2]
- Apache Struts 2.5.10.1 버전 [3]
o Content-Type에 엄격한 필터링 적용 및 ognl 표현식과 사용 금지
o commons-fileupload-x.x.x.jar 파일 삭제
※ 해당 파일 삭제 시 업로드 기능 사용 불가

궁금하신 사항이나 문의 하실 내용은 메일이나 전화 주시면 답변드리도록 하겠습니다.
감사합니다.


첨부파일